发布于 2016-04-24 20:43:51 | 92 次阅读 | 评论: 0 | 来源: 网友投递

这里有新鲜出炉的Ruby教程,程序狗速度看过来!

Ruby编程语言

Ruby,一种为简单快捷的面向对象编程(面向对象程序设计)而创的脚本语言,在20世纪90年代由日本人松本行弘开发,遵守GPL协议和Ruby License。它的灵感与特性来自于 Perl、Smalltalk、Eiffel、Ada以及 Lisp 语言。


这篇文章主要介绍了Windows下安装配置Ruby的debug工具ruby-debug-base19的方法,同时讲解了Ruby的IDE RubyMine中的相关配置方法,需要的朋友可以参考下

gem使用代理的两种方式:

方式一: 


>>SET http_proxy=http://ip_or_host:PORT 
>>gem install the_package_name 
方式二: 

>>gem list -p http://user:[email protected]_or_host:8080 -r 

安装ruby-debug-base19
有2种方法:
方法一:
先下载.gem文件,然后直接安装.gem文件,这种需要编译,所以需要带with-ruby-include参数,这个是ruby的开发编译包


>>curl -OL http://rubyforge.org/frs/download.php/75414/linecache19-0.5.13.gem  
>>curl -OL http://rubyforge.org/frs/download.php/75415/ruby-debug-base19-0.11.26.gem   
>>gem install linecache19-0.5.13.gem ruby-debug-base19-0.11.26.gem -- --with-ruby-include=$rvm_path/src/ruby-1.9.3-p125/  

方法二:
下载免编译的windows版本的ruby-debug.

最后使用代理安装ruby-debug-base19

>>gem install ruby-debug-base19 -p http://ip_or_host:8080 -r -- --with-ruby-include=D:/ruby-1.9.3-p125/ 


gem 还可以查看远程的安装库包,以区别本地安装库

gem list -r 
gem install -r gem_package_name 

rubymine IDE中的配置
在rubymine中,如果ruby解释器选择的是1.9.3,那么调试时就必须安装ruby-debug-base19x,安装其他的都不行,即使是ruby-debug-base193,但是安装这个经常会报错。在大神胜博发888手机平台stackoverflow.com上查找到答案。


curl -L "http://rubyforge.org/frs/download.php/75414/linecache19-0.5.13.gem" -o /tmp/linecache19-0.5.13.gem 
gem install linecache19-0.5.13.gem -- --with-ruby-include=D:\ruby-1.9.3-p125 
gem install ruby-debug-base19x -v 0.11.30.pre10 
gem install ruby-debug-ide -v 0.4.17.beta14 

如果还报错,那么就是卸载掉所有的ruby-debug-base版本,在重新安装.
在rubymine中,如果ruby解释器选择的是1.9.3,那么调试时就必须安装ruby-debug-base19x,安装其他的都不行,即使是ruby-debug-base193,但是安装这个经常会报错。在大神胜博发888手机平台stackoverflow.com上查找到答案。


curl -L "http://rubyforge.org/frs/download.php/75414/linecache19-0.5.13.gem" -o /tmp/linecache19-0.5.13.gem 
gem install linecache19-0.5.13.gem -- --with-ruby-include=D:\ruby-1.9.3-p125 
gem install ruby-debug-base19x -v 0.11.30.pre10 
gem install ruby-debug-ide -v 0.4.17.beta14 

如果还报错,那么就是卸载掉所有的ruby-debug-base版本,在重新安装.



相关阅读 :
Windows下安装配置Ruby的debug工具ruby-debug-base19
linux下安装Ruby的三种方法
Windows下Ruby+Watir自动化测试的环境搭建及数据读取
Ruby环境下安装使用bundler来管理多版本的gem
CentOS 7下配置Ruby语言开发环境的方法教程
windows和linux下Ruby的下载与安装
win7下从ruby源代码编译安装的方法
iOS Mac系统下Ruby环境安装
在操作系统上安装Ruby解释器的教程
Ubuntu系统安装Ruby语言的三种方法
CentOS 6.3下编译安装Ruby 2.0笔记
Ruby入门点滴-Ruby的安装
最新网友评论  共有(0)条评论 发布评论 返回顶部
月排行榜

Copyright © 2007-2017 PHPERZ.COM All Rights Reserved   冀ICP备14009818号  版权声明  服务